archrelease: copy trunk to community-any
[ArchLinux/community.git] / aws-c-compression / repos / community-x86_64 / PKGBUILD
blobf6fd7011c824b8d6f18a654685dd18bda341e19a
1 # Maintainer: Anatol Pomozov
3 pkgname=aws-c-compression
4 pkgver=0.2.16
5 pkgrel=1
6 pkgdesc='C99 implementation of huffman encoding/decoding'
7 arch=(x86_64)
8 url='https://github.com/awslabs/aws-c-compression'
9 license=(Apache)
10 depends=(aws-c-common)
11 makedepends=(cmake)
12 source=(aws-c-compression-$pkgver.zip::https://github.com/awslabs/aws-c-compression/archive/v$pkgver.zip)
13 sha256sums=('a3434734637c94c3f516f0c91fb5ac13cd76faabcbdc574267e0cf903d9193d8')
15 build() {
16   cd aws-c-compression-$pkgver
18   cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -S . -B build
19   cmake --build build
22 check() {
23   cd aws-c-compression-$pkgver
24   cmake --build build --target test
27 package() {
28   cd aws-c-compression-$pkgver
30   cmake --build build --target install -- DESTDIR="$pkgdir/"
31   install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"