archrelease: copy trunk to community-any
[ArchLinux/community.git] / aws-c-http / repos / community-x86_64 / PKGBUILD
blob82c100fc6cb2e891d57d81b52ad2f2c32143049a
1 # Maintainer: Anatol Pomozov
3 pkgname=aws-c-http
4 pkgver=0.7.7
5 pkgrel=1
6 pkgdesc='C99 implementation of the HTTP/1.1 and HTTP/2 specifications'
7 arch=(x86_64)
8 url='https://github.com/awslabs/aws-c-http'
9 license=(Apache)
10 depends=(aws-c-common aws-c-compression aws-c-io)
11 makedepends=(cmake)
12 source=(aws-c-http-$pkgver.zip::https://github.com/awslabs/aws-c-http/archive/v$pkgver.zip)
13 sha256sums=('c8e83504509d7db0e11c46966087399db7a88fb7f2a81e94cbc6bded864af6a8')
15 build() {
16   cd aws-c-http-$pkgver
18   cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -S . -B build
19   cmake --build build
22 check() {
23   cd aws-c-http-$pkgver
24   cmake --build build --target test
27 package() {
28   cd aws-c-http-$pkgver
30   cmake --build build --target install -- DESTDIR="$pkgdir/"
31   install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"