archrelease: copy trunk to community-any
[ArchLinux/community.git] / bash-bats-support / trunk / PKGBUILD
blob1872ac9eeb19ed5e2c023c308be3d8c301af1cef
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Jan-Erik Rediger <badboy at archlinux dot us>
4 pkgname=bash-bats-support
5 pkgver=0.3.0
6 pkgrel=3
7 pkgdesc="Supporting library for Bats test helpers"
8 arch=("any")
9 url="https://github.com/ztombol/bats-support"
10 license=("custom:CC0")
11 depends=('bash-bats')
12 source=("https://github.com/ztombol/bats-support/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
13 sha512sums=('417a8054462a44a6f46e375526cc1c920bae54ea76ddec3ff46603fe68bdb5c58f51bfb1c7e066347a3b71ff4d43986fd5157eb55151e0c4b5d189d81282ea14')
15 check() {
16   cd bats-support-$pkgver
17   bats test
20 package() {
21   cd bats-support-$pkgver
23   for fn in *.bash; do
24     install -Dm755 $fn \
25       "$pkgdir"/usr/lib/bats-support/$(basename $fn)
26   done
28   for fn in src/*.bash; do
29     install -Dm755 $fn \
30       "$pkgdir"/usr/lib/bats-support/src/$(basename $fn)
31   done
33   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE