1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Frederik Schwan <freswa at archlinux dot org>
3 # Contributor: Peter Wu <peter@lekensteyn.nl>
4 # Contributor: Miguel Revilla <yo@miguelrevilla.com>
5 # Contributor: s1gma <s1gma@mindslicer.com>
10 pkgdesc='Tool for searching a given binary image for embedded files'
11 url='https://github.com/ReFirmLabs/binwalk'
16 'python-opengl: binviz module support'
17 'python-capstone: disassembly support'
18 'arj: ARJ decompression support'
19 'cabextract: CAB archive support'
20 'cpio: CPIO archive support'
21 'gzip: GZIP decompression support'
22 'mtd-utils: JFFS filesystem support'
23 'p7zip: ZIP, LZMA and ISO decompression support'
24 'squashfs-tools: squashfs support'
25 'tar: TAR archive support'
26 'bzip2: BZIP2 archive support'
27 'unrar: RAR decompression support'
28 'xz: XZ decompression support'
30 'sleuthkit: forensic analysis support'
32 source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
33 sha512sums=('5a5e16035dfc05b94ae4ee3969a337336c550606b71e20fcb1f150c4b38ef2084b6a823ce2a8050f4b41616b7d7c31cfb04bf43e7f2c977ab1a634aba9d67fec')
34 b2sums=('a5eac4242402c5034c293432131950bed9aff762c5db86b200a1f555bdfeeb1c6fda225393149f7beca2923141f2ae7930738038f2d039513cb06dfae9601b81')
37 cd ${pkgname}-${pkgver}
42 cd ${pkgname}-${pkgver}
43 python setup.py install -O1 --prefix="${pkgdir}/usr"
44 install -Dm 644 *.md -t "${pkgdir}/usr/share/doc/${pkgname}"
45 install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"