archrelease: copy trunk to community-any
[ArchLinux/community.git] / blanket / trunk / PKGBUILD
blob02bac3d525538936b111894a0e89c9afe7efbfc4
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
4 pkgname=blanket
5 pkgver=0.6.0
6 pkgrel=2
7 pkgdesc='Improve focus and increase your productivity by listening to different sounds'
8 arch=('any')
9 url='https://github.com/rafaelmardojai/blanket'
10 license=('GPL3')
11 depends=('gst-plugins-bad-libs' 'gst-plugins-base' 'gst-plugins-good' 'gst-python' 'libadwaita' 'python-gobject')
12 makedepends=('appstream-glib' 'meson')
13 source=("https://github.com/rafaelmardojai/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha256sums=('710a3b733da5eb349bf8dc3c37ef0afeb301c8299c22e7fad3c753576f33f7f4')
16 build() {
17   arch-meson $pkgname-$pkgver build
18   meson compile -C build
21 check() {
22   meson test -C build --print-errorlogs
25 package() {
26   meson install -C build --destdir "$pkgdir"