archrelease: copy trunk to community-any
[ArchLinux/community.git] / bliss / trunk / PKGBUILD
blob7e50be0c5fd5b3356f3fde1edb7494e31a8b83a6
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=bliss
4 pkgver=0.77
5 pkgrel=2
6 pkgdesc='A library for computing automorphism groups and canonical forms of graphs'
7 arch=(x86_64)
8 url='https://users.aalto.fi/~tjunttil/bliss/'
9 license=(GPL3)
10 depends=(gmp)
11 makedepends=(cmake)
12 source=(https://users.aalto.fi/~tjunttil/bliss/downloads/$pkgname-$pkgver.zip
13         digraph_heuristic.patch
14         make-install.patch)
15 sha256sums=('acc8b98034f30fad24c897f365abd866c13d9f1bb207e398d0caf136875972a4'
16             '584dbb948c5ad39c32373a3736d457ef5ecf0c23b552d9e925fa0ace61652461'
17             '1cbbcf33c779c832787ad2b6770643b2a3f9ddbe2077217820fe5ac5ca902f16')
19 prepare() {
20   patch -d $pkgname-$pkgver -p1 < digraph_heuristic.patch # Fix splitting heuristics for digraphs
21   patch -d $pkgname-$pkgver -p1 < make-install.patch # Add make install target
24 build() {
25   cmake -B build -S bliss-$pkgver \
26     -DCMAKE_INSTALL_PREFIX=/usr \
27     -DUSE_GMP=OFF
28   cmake --build build
31 package() {
32   DESTDIR="$pkgdir" cmake --install build