archrelease: copy trunk to community-any
[ArchLinux/community.git] / bolt / trunk / PKGBUILD
blobb84fb71bef633fa0b1012152e481e768111e3f6b
1 # Maintainer: Morten Linderud <foxboron@archlinux.org>
2 # Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
4 pkgname=bolt
5 pkgver=0.9.5
6 pkgrel=1
7 pkgdesc="Thunderbolt 3 device manager"
8 arch=('x86_64')
9 url="https://gitlab.freedesktop.org/bolt/bolt"
10 license=('LGPL')
11 depends=('polkit' 'systemd')
12 makedepends=('asciidoc' 'meson' 'python-setuptools' 'patch')
13 checkdepends=('umockdev')
14 source=(https://gitlab.freedesktop.org/$pkgname/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('478b0a71da5587c0e142a3b91e821a7d857260647494fa9544d2d8df05d560f6')
17 build() {
18   cd $pkgname-$pkgver
20   arch-meson ../build
21   ninja -v -C ../build
24 check() {
25   cd $pkgname-$pkgver
27   meson test -C ../build --print-errorlogs
30 package() {
31   cd $pkgname-$pkgver
33   DESTDIR="${pkgdir}" meson install -C ../build
34   install -d -o root -g 102 -m 750 "$pkgdir/usr/share/polkit-1/rules.d"