archrelease: copy trunk to community-any
[ArchLinux/community.git] / bshapr / trunk / PKGBUILD
blob598f3fc2d4db5ccd03f5714888da91715cc14c4e
1 # Maintainer: David Runge <dvzrv@archlinux.org>
3 _name=BShapr
4 _plugin_uri="https://www.jahnichen.de/plugins/lv2/BShapr"
5 pkgname=bshapr
6 pkgver=0.13
7 pkgrel=2
8 pkgdesc="Beat/ envelope shaper LV2 plugin"
9 arch=(x86_64)
10 url="https://github.com/sjaehn/BShapr"
11 license=(GPL3)
12 groups=(
13   lv2-plugins
14   pro-audio
16 depends=(
17   cairo
18   gcc-libs
19   glibc
20   libx11
21   lv2-host
23 makedepends=(lv2)
24 checkdepends=(lv2lint)
25 source=($url/archive/v$pkgver/$_name-$pkgver.tar.gz)
26 sha512sums=('bf45571d7612e1ecce36d58b79202fc8316cbe01f7e070abe38ef613b0f826ad12ff4944101c6363636f5253178c311788d1027f41aacc01ee4233383f9e8908')
27 b2sums=('a6953f65c2b31bf064fdcd24458ee27dbb020691b460111e3e5b65b79eeae1af1f64f30cb4e1f595ceaf5a52c905c9de4a41d378fe300cc623a5a424a249538c')
29 build() {
30   make -C $_name-$pkgver
33 check() {
34   # upstream doesn't care about validation: https://github.com/sjaehn/BShapr/issues/7
35   lv2lint -t "Plugin Version Minor" -t "Plugin Version Micro" -t "UI Symbols" -Mpack -I $_name-$pkgver/$_name.lv2/ "$_plugin_uri"
38 package() {
39   make PREFIX=/usr DESTDIR="$pkgdir/" install -C $_name-$pkgver
40   install -vDm 644 $_name-$pkgver/README.md -t "$pkgdir/usr/share/doc/$pkgname/"