archrelease: copy trunk to community-any
[ArchLinux/community.git] / byuu / trunk / PKGBUILD
blobd08d88a274109e83cce57b3501d4f4bc32e17a7f
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=byuu
4 pkgver=4
5 pkgrel=1
6 pkgdesc='A multi-system emulator focused on performance, features, and ease of use'
7 arch=(x86_64)
8 url=https://byuu.org/
9 license=(GPL3)
10 depends=(
11   gcc-libs
12   glibc
13   libao
14   libasound.so
15   libgl
16   libpulse-simple.so
17   libpulse.so
18   libudev.so
19   libx11
20   libxext
21   libxrandr
22   libxv
23   openal
24   qt5-base
25   sdl2
27 makedepends=(
28   git
30 source=(
31   git+https://github.com/byuu/byuu.git#tag=3455d1f5bd3dd72797660384f4a35c8b6dfeed64
32   git+https://github.com/byuu/bsnes.git#tag=8e80d2f8a43e34a82931e25143b279e5fbcfaedc
33   byuu-flags.patch
34   byuu-paths.patch
36 sha256sums=('SKIP'
37             'SKIP'
38             '514bce6f87f8ffc2476d0a5e5948fc79ab4470d0514d089cd8ac2386f8532730'
39             '5596804071813a5745d38eda21a9b2df6470f24db27c1d99c7284cbc97f27fda')
41 pkgver() {
42   cd byuu
44   git describe --tags | sed 's/^v//'
47 prepare() {
48   cd byuu
50   patch -Np1 -i ../byuu-flags.patch
51   patch -Np1 -i ../byuu-paths.patch
52   sed 's|/usr/local/lib/qt5/bin/moc|moc|' -i hiro/GNUmakefile
55 build() {
56   cd byuu
58   make -C higan hiro=qt5
61 package() {
62   install -dm 755 "${pkgdir}"/usr/share/byuu
64   install -Dm 755 byuu/higan/out/byuu -t "${pkgdir}"/usr/bin/
65   install -Dm 644 byuu/higan/target-byuu/resource/byuu.desktop -t "${pkgdir}"/usr/share/applications/
66   install -Dm 644 byuu/higan/target-byuu/resource/byuu.png -t "${pkgdir}"/usr/share/pixmaps/
67   cp -dr --no-preserve='ownership' bsnes/bsnes/Database "${pkgdir}"/usr/share/byuu/
68   cp -dr --no-preserve='ownership' bsnes/shaders "${pkgdir}"/usr/share/byuu/Shaders
71 # vim: ts=2 sw=2 et: