archrelease: copy trunk to community-any
[ArchLinux/community.git] / calf / trunk / PKGBUILD
blobad587ec086abe26cea2e6257dc2cb8a1f2cc9fd3
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: David Runge <dave@sleepmap.de>
3 # Contributor: Ray Rashif <schiv@archlinux.org>
5 pkgname=calf
6 pkgver=0.90.3
7 pkgrel=6
8 pkgdesc='LV2 plug-in suite and standalone Jack host'
9 arch=(x86_64)
10 url="https://calf-studio-gear.org"
11 groups=(
12   lv2-plugins
13   pro-audio
15 license=(LGPL2.1)
16 depends=(
17   cairo
18   expat
19   fluidsynth
20   gcc-libs
21   gdk-pixbuf2
22   glib2
23   glibc
24   gtk2
25   hicolor-icon-theme
26   jack
28 makedepends=(lv2)
29 source=(https://calf-studio-gear.org/files/$pkgname-$pkgver.tar.gz)
30 sha512sums=('a17be4f2e753c5426ff6995ebf4e88f1d4916629f624fcb576e09e5cafd56474fc8944d9defba31561a3476c55d78dd69189cedb11197a09cc3af6e59aa2a867')
31 b2sums=('c34eebe4a80492f54f4af0ce136f489554959a0a605cd729a3138e368976aafb0fcf4827050aea6de3b276d1e6d5a67283eed88dd342aa8cf65ffcb3ff1cd86f')
33 prepare(){
34   cd $pkgname-$pkgver
35   autoreconf -fiv
38 build() {
39   local configure_options=(
40     --enable-experimental
41     --enable-sse
42     --prefix=/usr
43     --with-lv2
44   )
46   cd $pkgname-$pkgver
47   ./configure "${configure_options[@]}"
48   # prevent libtool from overlinking
49   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
50   make
53 package() {
54   make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
55   install -vDm 644 $pkgname-$pkgver/{AUTHORS,ChangeLog,README} -t "$pkgdir/usr/share/doc/$pkgname"