archrelease: copy trunk to community-any
[ArchLinux/community.git] / camlp-streams / repos / community-x86_64 / PKGBUILD
blob3058ad98a792f5568ed9c1812347b5abcd3e5625
1 # Maintainer: Jürgen Hötzel
2 pkgname="camlp-streams"
3 pkgver=5.0.1
4 _relname=v5.0.1
5 pkgrel=2
6 pkgdesc="The Stream and Genlex libraries for use with Camlp4 and Camlp5."
7 arch=('x86_64')
8 url="https://github.com/ocaml/camlp-streams"
9 license=('BSD')
10 makedepends=('dune')
11 depends=('ocaml' 'ocaml-compiler-libs')
12 options=('!strip')
13 source=("camlp-streams-${_relname}.tar.gz::https://github.com/ocaml/camlp-streams/archive/$_relname.tar.gz")
14 sha256sums=('ad71f62406e9bb4e7fb5d4593ede2af6c68f8b0d96f25574446e142c3eb0d9a4')
17 build() {
18     cd "${srcdir}/${pkgname}-${pkgver}"
19     dune build
22 package() {
23     cd "${srcdir}/${pkgname}-${pkgver}"
24     DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir="$(ocamlc -where)"
26     install -dm755 "${pkgdir}/usr/share/"
27     mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
29     install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"