archrelease: copy trunk to community-any
[ArchLinux/community.git] / camlp4 / trunk / PKGBUILD
blob3e4b56004621e956d70c3a03e23d0c6c9f43ef2f
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Tobias Powalowski <tpowa@archlinux.org>
4 pkgname=camlp4
5 _ocaml_ver=5.0.0
6 pkgver=${_ocaml_ver%.*}+1
7 pkgrel=1
8 pkgdesc='Caml preprocessor and pretty-printer'
9 arch=(x86_64)
10 license=(GPL2)
11 url='https://github.com/ocaml/camlp4/releases'
12 depends=("ocaml")
13 makedepends=(git ocamlbuild ocaml-compiler-libs ocaml-findlib camlp-streams)
14 options=(!makeflags !emptydirs staticlibs)
15 _ocaml_5_commit=862936ff67fe01f8e2e35e667e4a7f2990ebc300
16 source=("$pkgname-$pkgver.tar.gz::https://github.com/ocaml/camlp4/archive/${_ocaml_5_commit}.tar.gz")
17 b2sums=('74cdc24c957f826778546121555ef2914330d1da5fea8eef83b7c183f779f62fc2f20fece533e4dff3102495252dcaa07680358aeb0f7449899d91b891dbbbcf')
18 build() {
19   cd "$pkgname-${_ocaml_5_commit}"
20   CFLAGS+=' -ffat-lto-objects -w'
21   ./configure
22   make all camlp4/META
25 package() {
26   cd "$pkgname-${_ocaml_5_commit}"
27   make \
28     BINDIR="$pkgdir/usr/bin" \
29     LIBDIR="$pkgdir/usr/lib/ocaml" \
30     PKGDIR="$pkgdir/usr/lib/ocaml" \
31     install install-META