1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="A tool for manipulating CBOR"
7 url="https://github.com/well-typed/cborg"
10 depends=('ghc-libs' 'haskell-aeson' 'haskell-aeson-pretty' 'haskell-cborg' 'haskell-cborg-json'
11 'haskell-scientific' 'haskell-unordered-containers' 'haskell-vector')
12 makedepends=('ghc' 'uusi')
13 source=("https://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha256sums=('d720f1caa98153bebea7ade4a0f1f53010a5febd2d53925c945e26f8c3b75667')
18 uusi -u aeson -u vector $pkgname.cabal
24 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-cbor-tool --enable-tests \
26 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
30 runhaskell Setup build $MAKEFLAGS
35 runhaskell Setup test --show-details=direct
41 runhaskell Setup copy --destdir="$pkgdir"
42 install -D -m644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname/
43 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE.txt