archrelease: copy trunk to community-any
[ArchLinux/community.git] / cjdns / repos / community-x86_64 / PKGBUILD
bloba0f0c295f0fb129a9280ea7374ace68b1d535814
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: kpcyrd <kpcyrd[at]archlinux[dot]org>
3 # Contributor: Kevin MacMartin <prurigro@gmail.com>
4 # Contributor: openfbt
5 # Contributor: Werecat
6 # Contributor: Xyne
8 pkgname=cjdns
9 pkgver=22
10 pkgrel=1
11 pkgdesc='Routing engine designed for security, scalability, speed and ease of use'
12 url='https://github.com/cjdelisle/cjdns'
13 arch=('x86_64')
14 license=('GPL3')
15 depends=('glibc' 'sh')
16 optdepends=('nodejs: optional utilities support')
17 makedepends=('nodejs' 'python' 'libseccomp' 'util-linux' 'which' 'audit' 'rust' 'linux-headers')
18 install=cjdns.install
19 source=(${pkgname}-${pkgver}.tar.gz::https://github.com/cjdelisle/${pkgname}/archive/cjdns-v${pkgver}.tar.gz)
20 sha512sums=('fd22ae084edf174052b2683fc5591aeb036791b1a710f49d57cab475b1fdc7e7a2d4fcc3482d5fd401e15b8fef49a8985bea93a4b5a192c62b31647c4667b610')
21 b2sums=('06bd852cd22e93eea9f215409253270f0ba1e781a50d2c333f14c1ddac3eec4f93c02c93cb55adca26b76aab1586d85a3e559aa250ce0ddbf8ee2d6ca134b4c8')
23 build() {
24   cd ${pkgname}-${pkgname}-v${pkgver}
25   export CROSS="true"
26   export CJDNS_RELEASE_VERSION="${pkgver}"
27   "./cross-do"
30 package() {
31   cd ${pkgname}-${pkgname}-v${pkgver}
32   install -Dm 755 cjdroute -t "${pkgdir}/usr/bin"
33   install -Dm 644 contrib/systemd/{cjdns,cjdns-resume}.service \
34     -t "${pkgdir}/usr/lib/systemd/system"
35   install -Dm 644 doc/man/cjdroute.conf.5 -t "${pkgdir}/usr/share/man/man5"
36   install -Dm 644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
37     README.md \
38     doc/admin-api.md \
39     doc/configure.md \
40     doc/djc_layer_model.md \
41     doc/nat-gateway.md \
42     doc/network-services.md \
43     doc/non-root-user.md \
44     doc/security_specification.md \
45     doc/shorewall_and_vpn_gateway_howto.md \
46     doc/tunnel.md
47   cp -a tools "${pkgdir}/usr/lib/${pkgname}"
48   cp -a node_modules "${pkgdir}/usr/lib/${pkgname}/node_modules"
51 # vim: ts=2 sw=2 et: