archrelease: copy trunk to community-any
[ArchLinux/community.git] / confuse / trunk / PKGBUILD
blobabaf0f3c03a1ca3329f753bb46fb07ec5cdcbf6c
1 # Maintainer: Konstantin Gizdov <arch at kge dot pw>
2 # Contributor : Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Roman Kyrylych <roman@archlinux.org>
4 # Contributor: Alexander Mieland (dma147) <dma147@linux-stats.org>
5 # Contributor: Thorsten Töpper <atsutane-tu@freethoughts.de>
6 # Contributor: Baptiste Jonglez <baptiste--aur at jonglez dot org>
8 pkgname=confuse
9 pkgver=3.3
10 pkgrel=3
11 pkgdesc='C-library for parsing configuration files'
12 arch=('x86_64')
13 url='https://github.com/libconfuse/libconfuse'
14 license=('ISC')
15 depends=('glibc')
16 source=("https://github.com/libconfuse/libconfuse/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
17 options=('!emptydirs')
18 sha256sums=('3a59ded20bc652eaa8e6261ab46f7e483bc13dad79263c15af42ecbb329707b8')
20 build() {
21   cd "${srcdir}/${pkgname}-${pkgver}"
22   ./configure --prefix=/usr --enable-shared
23   make
26 check() {
27   cd "${srcdir}/${pkgname}-${pkgver}"
28   make check
31 package() {
32   cd "${srcdir}/${pkgname}-${pkgver}"
33   make DESTDIR="${pkgdir}" install
34   install -D -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" LICENSE