archrelease: copy trunk to community-any
[ArchLinux/community.git] / coxeter / trunk / PKGBUILD
blob62e4ff41f62af394a8f3f5b5a068e90e610973d6
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=coxeter
4 pkgver=git.20180226
5 pkgrel=3
6 _commit=7b5a1f0039511326aeb616afb132a5065886b9d8
7 pkgdesc="A library for the study of combinatorial aspects of Coxeter group theory"
8 arch=(x86_64)
9 url="https://github.com/tscrim/coxeter"
10 license=(GPL3)
11 depends=(gcc-libs)
12 makedepends=(git)
13 conflicts=(coxeter3)
14 replaces=(coxeter3)
15 source=("git+https://github.com/tscrim/coxeter#commit=$_commit" coxeter-sage.patch coxeter-makefile.patch)
16 sha256sums=('SKIP'
17             '668235f7858c4542d2856d6b36f2f1d18f14ffea685a96637992a14613a71688'
18             'dc82e9ce42ebd0f00eca08e771d4115370053b75d3dac1368620a1c66292c030')
20 prepare() {
21   cd coxeter
22 # Add Sage patches
23   patch -p1 -i ../coxeter-sage.patch
24   patch -p1 -i ../coxeter-makefile.patch
25 }  
27 build() {
28   cd coxeter
30   make all
33 package() {
34   cd coxeter
35   mkdir -p "$pkgdir"/usr/{lib,bin}
36   make SAGE_LOCAL="$pkgdir/usr" install