archrelease: copy trunk to community-any
[ArchLinux/community.git] / crun / repos / community-x86_64 / PKGBUILD
blob7251d050b7ccf2ed072f949db4f0c89122378b45
1 # Maintainer: Morten Linderud <foxboron@archlinux.org>
2 # Contributor: hexchian <i at hexchain dot org>
4 pkgname=crun
5 pkgver=1.8.4
6 pkgrel=1
7 pkgdesc="A fast and lightweight fully featured OCI runtime and C library for running containers"
8 url="https://github.com/containers/crun"
9 license=('LGPL')
10 arch=('x86_64')
11 provides=('oci-runtime')
12 depends=('yajl' 'systemd-libs' 'libcap' 'libseccomp' 'criu')
13 makedepends=('libtool' 'python' 'go-md2man' 'systemd' 'git')
14 source=("https://github.com/containers/crun/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"{,.asc})
15 validpgpkeys=('AC404C1C0BF735C63FF4D562263D6DF2E163E1EA')
16 sha256sums=('0d2475d1dbcfed224f21e740782c7a7c45c53444eb7b84a493764e2a0ee36166'
17             'SKIP')
19 build() {
20     cd "$pkgname-$pkgver"
21     ./autogen.sh
22     ./configure \
23         --prefix=/usr \
24         --enable-shared \
25         --enable-dynamic \
26         --with-python-bindings
27     make
30 package() {
31     cd "$pkgname-$pkgver"
32     make DESTDIR="$pkgdir" install