1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="The Language of Cryptography"
7 url="https://www.cryptol.net"
10 depends=('ghc-libs' 'z3' 'haskell-arithmoi' 'haskell-async' 'haskell-base-compat' 'haskell-bv-sized'
11 'haskell-cryptohash-sha1' 'haskell-extra' 'haskell-gitrev'
12 'haskell-graphscc' 'haskell-heredoc' 'haskell-libbf' 'haskell-memotrie'
13 'haskell-monad-control' 'haskell-monadlib' 'haskell-optparse-applicative'
14 'haskell-parameterized-utils' 'haskell-panic' 'haskell-prettyprinter' 'haskell-sbv'
15 'haskell-simple-smt' 'haskell-strict' 'haskell-temporary' 'haskell-tf-random'
16 'haskell-transformers-base' 'haskell-what4' 'haskell-ansi-terminal' 'haskell-blaze-html')
17 makedepends=('ghc' 'uusi' 'alex' 'happy')
18 source=(https://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz)
19 sha512sums=('a4979ca1a11fbbfb5f2f4741fa15ece50c76c84a194eea44844c4e88b4a371796e245be3b061429966db0f4013ca799b6096e152db7166c9d5833db654dc2121')
23 uusi -u what4 cryptol.cabal
29 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
30 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
31 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
32 -f-static -f-relocatable --ghc-option='-pie'
33 runhaskell Setup build $MAKEFLAGS
34 runhaskell Setup register --gen-script
35 runhaskell Setup unregister --gen-script
36 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
37 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
42 runhaskell Setup test --show-details=direct
48 install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
49 install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
50 runhaskell Setup copy --destdir="${pkgdir}"
51 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
52 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE