archrelease: copy trunk to community-any
[ArchLinux/community.git] / cutefish-settings / trunk / PKGBUILD
blobe186becb4469dd53d7d8d19dc07343d69e4340a1
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=cutefish-settings
4 pkgver=0.8
5 pkgrel=3
6 pkgdesc="System Settings application for Cutefish Desktop"
7 arch=('x86_64')
8 url="https://github.com/cutefishos/settings"
9 license=('GPL')
10 groups=('cutefish')
11 depends=('fishui' 'fontconfig' 'freetype2' 'icu' 'kcoreaddons' 'libxcursor'
12          'modemmanager-qt' 'networkmanager-qt'
13          # qml:
14          'bluez-qt' 'bluedevil' 'libcutefish' 'qt5-quickcontrols')
15 makedepends=('extra-cmake-modules' 'ninja' 'qt5-tools')
16 source=("https://github.com/cutefishos/settings/archive/$pkgver/$pkgname-$pkgver.tar.gz")
17 sha512sums=('abb724e999b0f339cd90a36efef3ce4249da24a186c33d026ac1ca30c858b702025d0b8e3fe7f0116b2cc0d217917b7ce1257c8f255b7ca4b8593c2031805e9c')
19 build() {
20   cd settings-$pkgver
22   cmake -DCMAKE_INSTALL_PREFIX=/usr .
23   make
26 package() {
27   cd settings-$pkgver
28   make DESTDIR="$pkgdir" install