1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Metal A-wing <1 at 233 dot email>
6 _commit=39ece1fe0ddacc2cbf182403c9e7085bc01df5a6
8 pkgdesc="A secure runtime for JavaScript and TypeScript"
10 url="https://deno.land"
14 makedepends=('git' 'python' 'cargo' 'nodejs')
15 source=("git+https://github.com/denoland/deno.git#commit=$_commit")
20 git submodule update --init --recursive
30 ./target/release/deno run cli/tests/testdata/run/002_hello.ts
35 install -Dm755 target/release/deno "$pkgdir"/usr/bin/deno
37 install -dm755 "$pkgdir"/usr/share/bash-completion/completions
38 ./target/release/deno completions bash > "$pkgdir"/usr/share/bash-completion/completions/deno
39 install -dm755 "$pkgdir"/usr/share/zsh/site-functions
40 ./target/release/deno completions zsh > "$pkgdir"/usr/share/zsh/site-functions/_deno
41 install -dm755 "$pkgdir"/usr/share/fish/vendor_functions.d
42 ./target/release/deno completions fish > "$pkgdir"/usr/share/fish/vendor_functions.d/deno.fish
44 install -Dm644 LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname/