1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc='Compile Dhall to Bash'
7 url='https://dhall-lang.org'
10 depends=('ghc-libs' 'dhall' 'haskell-neat-interpolation' 'haskell-shell-escape'
11 'haskell-optparse-generic')
13 source=("https://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
14 sha512sums=('1936c795f843af2fd5556f0e2cb041218bdb3a205a0e35d215a24d235a615c2e6267f06cb4e58848c2dc6319bfbd306e3cae8321e41f25e9326f28737071b9a6')
19 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22 runhaskell Setup build $MAKEFLAGS
23 runhaskell Setup register --gen-script
24 runhaskell Setup unregister --gen-script
25 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 runhaskell Setup test --show-details=direct
36 install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
37 install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
38 runhaskell Setup copy --destdir="${pkgdir}"
39 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
40 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE