archrelease: copy trunk to community-any
[ArchLinux/community.git] / dhall-bash / trunk / PKGBUILD
blob607a3dc084f4f9fa9b54940ceb295725417d41d3
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=dhall-bash
4 pkgver=1.0.40
5 pkgrel=166
6 pkgdesc='Compile Dhall to Bash'
7 url='https://dhall-lang.org'
8 license=('BSD')
9 arch=('x86_64')
10 depends=('ghc-libs' 'dhall' 'haskell-neat-interpolation' 'haskell-shell-escape'
11          'haskell-optparse-generic')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
14 sha512sums=('1936c795f843af2fd5556f0e2cb041218bdb3a205a0e35d215a24d235a615c2e6267f06cb4e58848c2dc6319bfbd306e3cae8321e41f25e9326f28737071b9a6')
16 build() {
17     cd $pkgname-$pkgver
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22     runhaskell Setup build $MAKEFLAGS
23     runhaskell Setup register --gen-script
24     runhaskell Setup unregister --gen-script
25     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
29 check() {
30     cd $pkgname-$pkgver
31     runhaskell Setup test --show-details=direct
34 package() {
35     cd $pkgname-$pkgver
36     install -D -m744 register.sh   "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
37     install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
38     runhaskell Setup copy --destdir="${pkgdir}"
39     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
40     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE