archrelease: copy trunk to community-any
[ArchLinux/community.git] / dhcping / trunk / PKGBUILD
blob920b284056ac8d66db8038f57344bd1a9b1286b8
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: enzzzzy <enzzzzy ta gmail dot com>
4 pkgname=dhcping
5 pkgver=1.2
6 pkgrel=3
7 pkgdesc='Small tool to let you perform a dhcp-request to find out if a dhcp-server is still running'
8 url='https://www.mavetju.org/unix/general.php'
9 arch=('x86_64')
10 license=('BSD')
11 depends=('glibc')
12 source=(https://www.mavetju.org/download/${pkgname}-${pkgver}.tar.gz)
13 sha256sums=('32ef86959b0bdce4b33d4b2b216eee7148f7de7037ced81b2116210bc7d3646a')
14 sha512sums=('84ead27ba07f7ecc1e8cf6d95b40c98ee20a39ce54386249f403120beac70c45d765d5268b4968dbfbbb92790adcc1eb648c3a87071d215ad64bcd23aec818d3')
16 build() {
17   cd ${pkgname}-${pkgver}
18   ./configure \
19     --prefix=/usr  \
20     --build=${CHOST} \
21     --host=${CHOST} \
22     --mandir=/usr/share/man
23   make
26 check() {
27   cd ${pkgname}-${pkgver}
28   make check
31 package () {
32   cd ${pkgname}-${pkgver}
33   make DESTDIR="${pkgdir}" install
34   install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
37 # vim: ts=2 sw=2 et: