archrelease: copy trunk to community-any
[ArchLinux/community.git] / diffpdf / trunk / PKGBUILD
blob74aba40abc652ebace2ad4a14e4030c974e9f6e7
1 # Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
2 # Contributor: Hoàng Đức Hiếu <arch@zahe.me>
3 # Contributor: Fernando
4 # Contributor: Manfred Sauter
5 # Contributor: Marcos Heredia <chelqo@gmail.com>
7 pkgname=diffpdf
8 pkgver=2.1.3.1
9 pkgrel=3
10 pkgdesc="Diffing pdf files visually or textually"
11 url="https://gitlab.com/eang/diffpdf"
12 license=('GPL2')
13 arch=('x86_64')
14 depends=('poppler-qt5' 'hicolor-icon-theme')
15 makedepends=('cmake' 'extra-cmake-modules' 'qt5-tools')
16 source=("https://gitlab.com/eang/diffpdf/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
17 sha512sums=('9213fc8ee9d568ad97824d30de1ffb137c30c58935f8a19e19690e956cd4db1a0c6020d0543f76ca1b4ca8858d7ce9329544bda6a68b943b00e1a581cdb1ed41')
19 build() {
20   cd ${pkgname}-v${pkgver}/
21   cmake -D CMAKE_INSTALL_PREFIX="/usr" .
22   make
25 package() {
26   cd ${pkgname}-v${pkgver}/
27   make DESTDIR="${pkgdir}" install
29   install -dm755 "${pkgdir}"/usr/share/${pkgname}/translations
30   install -Dm644 *.qm "${pkgdir}"/usr/share/${pkgname}/translations
31   install -Dm644 gpl-2.0.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE