archrelease: copy trunk to community-any
[ArchLinux/community.git] / duperemove / repos / community-x86_64 / PKGBUILD
blob6b8d4704f89a4b4becfad59e143f0b3661d5ca4d
1 # Maintainer: Robin Broda <coderobe @ archlinux.org>
2 # Contributor: Frederik Schwan <frederik dot schwan at linux dot com>
4 pkgname=duperemove
5 pkgver=0.11.3
6 pkgrel=2
7 pkgdesc='Btrfs extent deduplication utility'
8 arch=('x86_64')
9 url='https://github.com/markfasheh/duperemove'
10 license=('GPL')
11 depends=('glib2' 'sqlite')
12 source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
13 sha512sums=('0669cbb8a08082b9c2b62aff26759951e3e2c1b2236676ac6d79b9639027f775e4e5a218d1c7930b33ad7cca39726764cce5ac3063dc7d2049eb65fc4431af89')
15 build() {
16   cd "${pkgname}-${pkgver}"
17   CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
18   make
21 package() {
22   cd "${pkgname}-${pkgver}"
23   make PREFIX=/usr SBINDIR=/usr/bin DESTDIR="${pkgdir}" install