archrelease: copy trunk to community-any
[ArchLinux/community.git] / ecos / trunk / PKGBUILD
blob01edef02ca2f7d4f94c8a113db142ac7576df3c4
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Guillaume Horel <guillaume.horel@gmail.com>
4 pkgname=ecos
5 pkgver=2.0.10
6 pkgrel=2
7 pkgdesc='A lightweight conic solver for second-order cone programming'
8 url='https://github.com/embotech/ecos/wiki'
9 license=(GPL3)
10 arch=(x86_64)
11 depends=(glibc)
12 makedepends=(cmake)
13 source=(https://github.com/embotech/ecos/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('1aa24b5782b84fa33df2987510fb8f60f5f999cc2d3a5c73cfc3eb5e5f3b46af')
16 build() {
17   cmake -B build -S $pkgname-$pkgver \
18     -DCMAKE_INSTALL_PREFIX="/usr"
19   cmake --build build
22 package() {
23   DESTDIR="$pkgdir" cmake --install build