1 # Maintainer: Christian Rebischke <chris.rebischke@archlinux.org>
2 # Co-Maintainer: Santiago Torres-Arias <santiago@archlinux.org>
3 # Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
4 # Contributor: Andy Weidenbaum <archbaum@gmail.com>
9 pkgdesc="Lightweight Bitcoin wallet"
11 makedepends=('python-setuptools')
12 depends=('python-pyaes' 'python-ecdsa' 'python-pbkdf2' 'python-requests' 'python-qrcode'
13 'python-protobuf' 'python-dnspython' 'python-jsonrpclib-pelix' 'python-pysocks'
14 'python-pyqt5' 'python-pycryptodomex' 'python-websocket-client' 'python-certifi'
15 'python-aiorpcx' 'python-aiohttp' 'python-aiohttp-socks'
16 'libsecp256k1' 'python-bitstring')
17 optdepends=('python-btchip: BTChip hardware wallet support'
18 'python-hidapi: Digital Bitbox hardware wallet support'
19 'python-matplotlib: plot transaction history in graphical mode'
20 'zbar: QR code reading support'
21 'python-rpyc: send commands to Electrum Python console from an external script'
22 'python-qdarkstyle: optional dark theme in graphical mode'
23 'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
26 url="https://electrum.org"
28 source=("https://download.electrum.org/${pkgver}/${pkgname^}-${pkgver}.tar.gz"
29 "${pkgname^}-${pkgver}.tar.gz.asc::https://download.electrum.org/${pkgver}/${pkgname^}-${pkgver}.tar.gz.ThomasV.asc")
30 sha512sums=('6221b21c0da26008b81ba2787bb21f8cb298d11cb04b2c99ce60c68fbafdf213b7cec343d96d7a1aa9de6a605067a643479a33246a1ea4ba305c75022d5834cc'
32 validpgpkeys=('6694D8DE7BE8EE5631BED9502BD5824B7F9470E6')
35 cd "${pkgname^}-${pkgver}"
39 cd "${pkgname^}-${pkgver}"
45 cd "${pkgname^}-${pkgver}"
47 python setup.py install --root="${pkgdir}" --optimize=1
48 install -D -m644 LICENCE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE