archrelease: copy trunk to community-any
[ArchLinux/community.git] / emby-server / trunk / PKGBUILD
blob70a5964d843a4039f739d73520236da1b7f46feb
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Daniel Seymour <dannyseeless@gmail.com>
4 pkgname=emby-server
5 pkgver=4.7.11.0
6 _ffmpeg_ver=2022_05_07
7 _skiasharp_ver=2.80.2
8 pkgrel=1
9 pkgdesc='Bring together your videos, music, photos, and live television'
10 arch=(x86_64)
11 url=https://emby.media
12 license=(custom)
13 depends=(
14   alsa-lib
15   aom
16   aribb24
17   aspnet-runtime-6.0
18   bzip2
19   dotnet-runtime-6.0
20   expat
21   ffmpeg
22   fontconfig
23   fribidi
24   glibc
25   gmp
26   gnutls
27   lame
28   libass.so
29   libchromaprint.so
30   libdav1d.so
31   libdrm
32   libfreetype.so
33   libjpeg-turbo
34   libmfx
35   libpng
36   libtesseract.so
37   libtheora
38   libva-drm.so
39   libva.so
40   libvorbisenc.so
41   libvorbis.so
42   libwebp
43   libx264.so
44   libx265.so
45   opus
46   sqlite
47   zlib
48   zvbi
50 makedepends=(
51   ffnvcodec-headers
52   nasm
54 optdepends=(
55   'intel-media-sdk: Intel QuickSync support (requires Emby Premiere)'
56   'nvidia-utils: Nvidia NVDEC/NVENC support (requires Emby Premiere)'
58 source=(
59   https://github.com/MediaBrowser/Emby.Releases/releases/download/${pkgver}/embyserver-netcore_${pkgver}.zip
60   https://mediabrowser.github.io/embytools/ffmpeg-${_ffmpeg_ver}.tar.gz
61   https://mediabrowser.github.io/embytools/ffdetect-${_ffmpeg_ver}-x64.tar.xz
62   https://mediabrowser.github.io/embytools/libskiasharp-${_skiasharp_ver}-x64.tar.xz
63   emby-server
64   emby-server.conf
65   emby-server.service
66   license.docx
67   Permission_to_distribute.mbox
69 noextract=(license.docx)
70 backup=(etc/conf.d/emby-server)
71 install=emby-server.install
72 b2sums=('700b1bcfe2f603ae1a5a16c1aa3dbc787d4a0d732734ad8f66443054a0718c64c6e4b1b83b508667409b9dab180ebb0e491e80a4603cd26d4a3af1f573aea77d'
73         '0cf98666f22cb08bc02c5a93eb3d73e50648468da8d73edbd1814d2b3ca599532e75f3b597ff770c40712c04a4d1af5ab66b6bb6779b35508dd9e007e66e575d'
74         '39dbe0033cf43c77c92ae7e1e6709ae1cb447e8d9654b8b1422658d86994db6e2d04f65311e5f1a9a078bdf533344c37f0ab8e07138bb1eabe7108d87a79c2a0'
75         '08ea6a632c7366fb4086d3f42c602e85603bc416ec7e0ea1e7d41814441889fc4858db0128a4e433965ca2d7427f43028864d936b40244b3896fa78102ac38c6'
76         '48c11601d00121e725951fd48ba34137804d4a67aa12528a29ca4d43d301d19311182421e96bef7b7ddbc4929dc9d5b577b1659cb0b716b1c1f6938283465c46'
77         '49c2e6a27f36a2e44a6b988573ee7d08bacb036008f5360ad1cb617b3d1577bdcd48a323ebb882e0f9ec4483962a96d8bd9af44385feb5245b49dfc191d73352'
78         '11cc26f44f81823bcd50ee16344aff94eb0a64d740a2e489d832bc8d48d11f3065bf683da243409bab8e3d8a201083596a27983cc11a90688128442e0116430c'
79         'e490c2ec7aff3deb9874a80345273c2aa435624b914a13fe8cba8f07ee44938699a024d0c6784fe68820d3a848cccf5af3f7120c7906356ed17d306fc31b6490'
80         '61ca54af95278f498b21b424b4d4bae98660b4b7898bfd9752fe21da20d7c508502014bc1970a60920f3064ca20b31b46ba2a788b3b1371f75b5278add70ffc4')
82 prepare() {
83   rm -rf system/{electron,runtimes/{osx,tizen*,win*}}
86 build() {
87   cd ffmpeg-${_ffmpeg_ver}_public
88   ./configure \
89     --disable-doc \
90     --disable-ffplay \
91     --disable-shared \
92     --disable-vdpau \
93     --disable-libxcb \
94     --disable-lzma \
95     --disable-sdl2 \
96     --disable-xlib \
97     --enable-chromaprint \
98     --enable-fontconfig \
99     --enable-gmp \
100     --enable-gnutls \
101     --enable-gpl \
102     --enable-libaom \
103     --enable-libaribb24 \
104     --enable-libass \
105     --enable-libdav1d \
106     --enable-libdrm \
107     --enable-libfreetype \
108     --enable-libfribidi \
109     --enable-libmfx \
110     --enable-libmp3lame \
111     --enable-libopus \
112     --enable-libtesseract \
113     --enable-libtheora \
114     --enable-libvorbis \
115     --enable-libwebp \
116     --enable-libx264 \
117     --enable-libx265 \
118     --enable-libzvbi \
119     --enable-lto \
120     --enable-nvdec \
121     --enable-nvenc \
122     --enable-static \
123     --enable-vaapi \
124     --enable-version3
125   make
128 package() {
129   install -dm 755 "${pkgdir}"/usr/lib
130   cp -dr --no-preserve='ownership' system "${pkgdir}"/usr/lib/emby-server
131   install -Dm 755 emby-server -t "${pkgdir}"/usr/bin/
132   install -Dm 755 bin/ffdetect "${pkgdir}"/usr/bin/ffdetect-emby
133   install -Dm 755 ffmpeg-${_ffmpeg_ver}_public/ffmpeg "${pkgdir}"/usr/bin/ffmpeg-emby
134   install -Dm 755 ffmpeg-${_ffmpeg_ver}_public/ffprobe "${pkgdir}"/usr/bin/ffprobe-emby
135   install -Dm 755 lib/libSkiaSharp.so* -t "${pkgdir}"/usr/lib/emby-server/
136   install -Dm 644 emby-server.service -t "${pkgdir}"/usr/lib/systemd/system/
137   install -Dm 644 emby-server.conf "${pkgdir}"/etc/conf.d/emby-server
138   install -Dm 644 license.docx -t "${pkgdir}"/usr/share/licenses/emby-server/
141 # vim: ts=2 sw=2 et: