archrelease: copy trunk to community-any
[ArchLinux/community.git] / fcitx-cloudpinyin / trunk / PKGBUILD
blobade69892452a26eeb491ff3b83a9774dde6ec24d
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: poplarch <poplarch@gmail.com>
4 pkgname=fcitx-cloudpinyin
5 pkgver=0.3.7
6 pkgrel=1
7 pkgdesc='Standalone module for fcitx that uses pinyin API on the internet to provide additional input candidates'
8 arch=('x86_64')
9 url="https://github.com/fcitx/fcitx-cloudpinyin"
10 license=('GPL')
11 depends=('curl' 'fcitx')
12 makedepends=('cmake')
13 source=("https://download.fcitx-im.org/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
14 sha512sums=('1deb934fe9003aae519c8635fc8f13e21d1dcba4124b1b75c6e071b7ee903edf3fb9ce0eda5219fad5a78221eb6b157d2e731f1ff4cf49cb0643d87ddd55834b'
15             'SKIP')
16 validpgpkeys=('2CC8A0609AD2A479C65B6D5C8E8B898CBF2412F9') # Weng Xuetian <wengxt@gmail.com>
18 build() {
19   cd ${pkgname}-${pkgver}
21   cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .
22   make
25 package() {
26   cd ${pkgname}-${pkgver}
27   make DESTDIR="$pkgdir" install