archrelease: copy trunk to community-any
[ArchLinux/community.git] / fcitx-unikey / trunk / PKGBUILD
blob0aac450ee4269155a28198823d7e7fa4f62189cf
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=fcitx-unikey
4 pkgver=0.2.7
5 pkgrel=3
6 pkgdesc="Fcitx Wrapper for unikey"
7 arch=('x86_64')
8 url="https://github.com/fcitx/fcitx-unikey"
9 license=('GPL')
10 depends=('fcitx')
11 optdepends=('fcitx-qt5: To run the fcitx unikey macro editor')
12 makedepends=('cmake' 'fcitx-qt5')
13 source=("https://download.fcitx-im.org/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
14 sha512sums=('1bb78e4f27f0cda1e3aa5a633be45e0a26d121d5b472b1325b0c028ff65ca156d23e7ffee0367badeac1dd21ba1743ee8a2c9c27c629ae0996e84e0062b67ad2'
15             'SKIP')
16 validpgpkeys=('2CC8A0609AD2A479C65B6D5C8E8B898CBF2412F9') # Weng Xuetian <wengxt@gmail.com>
18 build() {
19   cd $pkgname-$pkgver
21   cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .
22   make
25 package() {
26   cd $pkgname-$pkgver
27   make DESTDIR="$pkgdir" install