archrelease: copy trunk to community-any
[ArchLinux/community.git] / firefox-adblock-plus / trunk / PKGBUILD
blobd25a29725d734fff623ace8d39cb011cf266461f
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Maintainer: Eli Schwartz <eschwartz@archlinux.org>
4 pkgname=firefox-adblock-plus
5 pkgver=3.16.2
6 pkgrel=1
7 _file=4080833
8 pkgdesc="Extension for firefox which block ads and banners"
9 arch=('any')
10 url="https://adblockplus.org/"
11 license=('GPL3')
12 checkdepends=('jq')
13 groups=('firefox-addons')
14 # https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/versions/
15 # wget -qO- https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/versions/ | grep -oP '/\d+/adblock_plus-\S+.xpi'
16 source=("https://addons.mozilla.org/firefox/downloads/file/${_file}/adblock-plus-${pkgver}.xpi")
17 noextract=("adblock-plus-$pkgver.xpi")
18 sha256sums=('a7b729b1d37c1636d8bdf2f3b04fc9a1b2beb08f4e4dba45a2f5ba71f6873e9a')
20 check() {
21   bsdtar xf adblock-plus-$pkgver.xpi manifest.json
22   jq '.version' manifest.json | grep -E '^"'$pkgver'"$'
25 package() {
26   depends=("firefox")
28   _extension_id="{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}"
29   _extension_dest="${pkgdir}/usr/lib/firefox/browser/extensions/${_extension_id}"
30   install -Dm644 "${srcdir}"/adblock-plus-${pkgver}.xpi "${_extension_dest}.xpi"