archrelease: copy trunk to community-any
[ArchLinux/community.git] / flameshot / repos / community-x86_64 / PKGBUILD
blob98111272854431e2cab87705cf110a70177059cd
1 # Maintainer: Jiachen YANG <farseerfc@archlinux.org>
2 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 # Contributor: xyzzy <628208@gmail.com>
5 pkgname=flameshot
6 pkgver=12.1.0
7 pkgrel=1
8 pkgdesc="Powerful yet simple to use screenshot software"
9 arch=('x86_64')
10 url="https://github.com/flameshot-org/flameshot"
11 license=('GPL')
12 depends=('qt5-svg' 'hicolor-icon-theme' 'kguiaddons')
13 makedepends=('make' 'qt5-tools' 'cmake')
14 optdepends=(
15     'gnome-shell-extension-appindicator: for system tray icon if you are using Gnome'
16     'grim: for wlroots wayland support'
17     'xdg-desktop-portal: for wayland support, you will need the implementation for your wayland desktop environment'
19 source=("${pkgname}-v${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
20 sha256sums=('c82c05d554e7a6d810aca8417ca12b21e4f74864455ab4ac94602668f85ac22a')
22 prepare() {
23   cd "${srcdir}/${pkgname}-${pkgver}"
24   mkdir -p build
27 build() {
28   cd "${srcdir}/${pkgname}-${pkgver}/build"
29   cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DUSE_WAYLAND_CLIPBOARD=1
30   make
33 package() {
34   cd "${srcdir}/${pkgname}-${pkgver}/build"
35   make DESTDIR="${pkgdir}" install
37   # zsh _flameshot completion is provided by zsh-completions so exclude from packaging
38   rm -rf ${pkgdir}/usr/share/zsh/