archrelease: copy trunk to community-any
[ArchLinux/community.git] / focuswriter / trunk / PKGBUILD
blob4c1bba5b234d2de0012e4061f01ea5e1bc5d04e7
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Graeme Gott <graeme@gottcode.org>
4 pkgname=focuswriter
5 pkgver=1.8.4
6 pkgrel=1
7 pkgdesc='Simple, distraction-free word processor'
8 arch=('x86_64')
9 url='https://gottcode.org/focuswriter/'
10 license=('GPL3')
11 depends=('hicolor-icon-theme' 'hunspell' 'qt6-multimedia' 'qt6-5compat')
12 makedepends=('cmake' 'qt6-tools')
13 source=("https://gottcode.org/$pkgname/$pkgname-$pkgver.tar.bz2"{,.asc})
14 sha256sums=('1bced0935d89df2aed09ab72891ce968787cf560e3a198e2b4d75af0c4064a0c'
15             'SKIP')
16 validpgpkeys=('57E4D43C10CD7EDB8360C84774FFC7F02C4F6B37')
18 build() {
19   cmake -B build -S $pkgname-$pkgver \
20     -DCMAKE_INSTALL_PREFIX=/usr
21   cmake --build build
24 package() {
25   DESTDIR="$pkgdir" cmake --install build