archrelease: copy trunk to community-any
[ArchLinux/community.git] / freeciv / trunk / PKGBUILD
blob9dc383c4ea0c8998e494280066ae7c513266a153
1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=freeciv
4 pkgver=3.0.7
5 pkgrel=1
6 pkgdesc="A multiuser clone of the famous Microprose game of Civilization"
7 arch=('x86_64')
8 url="http://www.freeciv.org/"
9 license=('GPL')
10 depends=('gtk3' 'sdl_mixer' 'lua53' 'sqlite' 'curl')
11 makedepends=('python')
12 backup=('etc/freeciv/database.lua')
13 source=(https://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.xz)
14 sha512sums=('b78fc6880348a5b8a53977930b8f2516414aad5c65ebce2aef12000931ff15b2e6786c1d6883da9e9e09d039a18eb91463b17b6a9467908ab3c052ef7fe94bfb')
16 build() {
17   cd ${pkgname}-${pkgver}
18   ./configure --prefix=/usr --sysconfdir=/etc --enable-shared --enable-sys-lua \
19     --enable-client=gtk3 --enable-fcmp=gtk3 --enable-fcdb=sqlite3 --enable-aimodules
20   make
23 package() {
24   cd ${pkgname}-${pkgver}
25   make DESTDIR="${pkgdir}" install