archrelease: copy trunk to community-any
[ArchLinux/community.git] / gdnsd / trunk / PKGBUILD
blob7f62295b97c3cdd766e4d86b9f0fe8281ccc3f08
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Daichi Shinozaki <dsdseg@gmail.com>
4 pkgname=gdnsd
5 pkgver=3.8.0
6 pkgrel=1
7 pkgdesc="an Authoritative-only DNS server which does geographic balancing, redirection, weighting, and service-state-conscious failover at the DNS layer"
8 arch=('x86_64')
9 url="https://gdnsd.org/"
10 license=('GPL3')
11 depends=('libev' 'libmaxminddb' 'libsodium' 'libunwind' 'liburcu')
12 makedepends=('ragel')
13 checkdepends=('perl-socket6' 'perl-io-socket-inet6' 'perl-http-daemon' 'perl-libwww' 'perl-net-dns')
14 source=("https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz"
15         gdnsd.sysusers)
16 sha512sums=('165c5576b1142a873dcd54b42f1b58a3ecd1958b274eb5e3c09fbd918b5851f554213605b062dea966cc7502d6e91ec79e32c121aba23ea4e560db6b488106af'
17             '8f39c0bed725d298314675b97610d37fc4dee31600c7f096deb38c63dba96e1b0c12239855154ea2c34f0ac3e8f5b7f1a86d9652210859982ab2339949b66e05')
19 prepare() {
20     cd "$pkgname-$pkgver"
21     autoreconf -vif
24 build() {
25     cd "$pkgname-$pkgver"
26     ./configure \
27        --prefix=/usr \
28       --sbindir=/usr/bin \
29       --localstatedir=/ \
30       --libexecdir=/usr/lib \
31       --sysconfdir=/etc \
32       --with-systemdsystemunitdir=/usr/lib/systemd/system
33       
34     make
37 check() {
38     cd "$pkgname-$pkgver"
39     make -k check
42 package() {
43     cd "$pkgname-$pkgver"
44     make DESTDIR="$pkgdir/" install
45     rm -rf "$pkgdir"/{lib,run}
47     install -Dm644 ../gdnsd.sysusers "$pkgdir/usr/lib/sysusers.d/gdnsd.conf"