archrelease: copy trunk to community-any
[ArchLinux/community.git] / gedit-code-assistance / trunk / PKGBUILD
blobc03c0d1862580ab4d3130461f37def3c24f7a09f
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gedit-code-assistance
5 pkgver=3.16.0+4+gd19b879
6 pkgrel=1
7 pkgdesc="Code assistance for gedit"
8 url="https://git.gnome.org/browse/gedit-code-assistance"
9 arch=(x86_64)
10 license=(GPL3)
11 depends=(gedit libgee gnome-code-assistance)
12 makedepends=(intltool gobject-introspection vala git)
13 _commit=d19b879e421ed43db779f6a26ac460f63c45b463  # master
14 options=(!makeflags)  # indentbackend build breaks, needs gca.vapi
15 source=("git://git.gnome.org/gedit-code-assistance#commit=$_commit"
16         fix-compile.diff)
17 sha256sums=('SKIP'
18             '7ebfe45ae3abc547af248397bd6a5b5d5063b666cc52f2660977a709d1fa3ec6')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/^v//;s/-/+/g'
25 prepare() {
26   cd $pkgname
27   patch -Np1 -i ../fix-compile.diff
28   NOCONFIGURE=1 ./autogen.sh
31 build() {
32   cd $pkgname
33   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
34   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
35   make
38 package(){
39   cd $pkgname
40   make DESTDIR="$pkgdir" install