archrelease: copy trunk to community-any
[ArchLinux/community.git] / gengetopt / trunk / PKGBUILD
blob457a30e5c490e941eb889d1f751e91b7be2c6cf8
1 # Maintainer: Christian Hesse <mail@eworm.de>
2 # Contributor: andreas_baumann <abaumann@yahoo.com>
3 # Contributor: zhuqin <zhuqin83@gmail.com>
5 pkgname=gengetopt
6 pkgver=2.23
7 pkgrel=2
8 pkgdesc='A tool to write command line option parsing code for C programs'
9 arch=('x86_64')
10 url='https://www.gnu.org/software/gengetopt/gengetopt.html'
11 license=('GPL')
12 options=('!docs' '!makeflags')
13 depends=('gcc-libs')
14 validpgpkeys=('CD7AB2B200F374043F92E5D42485C3A5CF0FF62F') # Gray Wolf <wolf@wolfsden.cz>
15 source=("https://ftp.gnu.org/gnu/gengetopt/${pkgname}-${pkgver}.tar.xz"{,.sig})
16 sha256sums=('b941aec9011864978dd7fdeb052b1943535824169d2aa2b0e7eae9ab807584ac'
17             'SKIP')
19 build() {
20         cd "${srcdir}/${pkgname}-${pkgver}"
22         ./configure --prefix=/usr
23         make
26 package() {
27         cd "${srcdir}/${pkgname}-${pkgver}"
29         make DESTDIR="${pkgdir}" install