archrelease: copy trunk to community-any
[ArchLinux/community.git] / gephi / repos / community-x86_64 / PKGBUILD
blobefff5202332cacd96ee96da26dedc083b0ebd4de
1 # Maintainer: Konstantin Gizdov <arch at kge dot pw>
2 # Contributor: Baptiste Jonglez <baptiste--aur at jonglez dot org>
3 # Contributor: Morten Linderud <morten@linderud.pw>
4 # Contributor: Andreas Krinke <andreas dot krinke at gmx dot de>
5 pkgname=gephi
6 pkgver=0.10.1
7 pkgrel=1
8 pkgdesc="An interactive graph visualization and exploration platform"
9 arch=('x86_64')
10 url="https://gephi.org"
11 license=('CDDL' 'GPL3')
12 depends=('java-runtime=11' 'java-environment=11' 'libxxf86vm' 'libnet' 'freetype2')
13 makedepends=('gendesk')
14 options=(!strip)
15 source=("https://github.com/gephi/gephi/releases/download/v$pkgver/gephi-$pkgver-linux-x64.tar.gz")
16 b2sums=('921d8b780043de03d8c9b538be3dce0c0f23623e1024ca5d37736f468533655985e480c48c944c55d90ab8309f22103dab44eefd82086ed0be8178aa9a2989c2')
18 prepare() {
19   gendesk -n --name "Gephi - The Open Graph Viz Platform" \
20     --pkgname "$pkgname" \
21     --pkgdesc "$pkgdesc"
24 package() {
25   cd "$srcdir/gephi-${pkgver}"
26   install -d "${pkgdir}/usr/share/java/${pkgname}"
27   cp -r * "${pkgdir}/usr/share/java/${pkgname}"
28   install -d "${pkgdir}/usr/bin"
29   ln -s "/usr/share/java/${pkgname}/bin/gephi" "${pkgdir}/usr/bin/gephi"
31   find "${pkgdir}" -type f -iname \*.dll -delete
32   find "${pkgdir}" -type f -iname \*.exe -delete
33   find "${pkgdir}" -type f -name .lastModified -delete
35   install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"