archrelease: copy trunk to community-any
[ArchLinux/community.git] / gf2x / repos / community-x86_64 / PKGBUILD
blobfd9ce204a074d043969e0148971e159e22543363
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=gf2x
4 pkgver=1.3.0
5 pkgrel=2
6 pkgdesc='A library for multiplying polynomials over the binary field'
7 arch=(x86_64)
8 url='https://gitlab.inria.fr/gf2x/gf2x'
9 license=(GPL LGPL)
10 depends=(glibc)
11 source=(https://gitlab.inria.fr/gf2x/gf2x/uploads/c46b1047ba841c20d1225ae73ad6e4cd/gf2x-$pkgver.tar.gz)
12 sha256sums=('9472cd651972a1de38e3c4c47697a86e0ecf19d7d33454d4bc2a62bc85841b59')
14 build() {
15   cd gf2x-$pkgver
16   ./configure --prefix=/usr --enable-sse2 --disable-pclmul CFLAGS="$CFLAGS -msse2"
17   make
20 check() {
21   cd gf2x-$pkgver
22   make -k check
25 package() {
26   cd gf2x-$pkgver
27   make prefix="$pkgdir"/usr install