archrelease: copy trunk to community-any
[ArchLinux/community.git] / gifsicle / repos / community-x86_64 / PKGBUILD
blobdc9020c27a378485a2c0e2eb6625be0d3e8014c3
1 # Maintainer : Daniel Bermond <dbermond@archlinux.org>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
4 pkgname=gifsicle
5 pkgver=1.93
6 pkgrel=2
7 pkgdesc='Command-line tool for creating, editing, and getting information about GIF images and animations'
8 arch=('x86_64')
9 url='https://www.lcdf.org/gifsicle/'
10 license=('GPL2')
11 depends=('libx11')
12 source=("https://www.lcdf.org/${pkgname}/${pkgname}-${pkgver}.tar.gz")
13 sha256sums=('92f67079732bf4c1da087e6ae0905205846e5ac777ba5caa66d12a73aa943447')
15 build() {
16     cd "${pkgname}-${pkgver}"
17     ./configure --prefix='/usr'
18     make
21 check() {
22     cd "${pkgname}-${pkgver}"
23     test/testie -p src test
26 package() {
27     make -C "${pkgname}-${pkgver}" DESTDIR="$pkgdir" install