1 # Maintainer: Christian Rebischke <chris.rebischke@archlinux.org>
2 # Maintainer: Robin Candau <antiz@archlinux.org>
3 # Contributor: Sébastien Luttringer <seblu@archlinux.org>
4 # Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
5 # Contributor: Francois Boulogne <fboulogne at april dot org>
10 pkgdesc='CLI curses-based monitoring tool'
12 url='https://nicolargo.github.io/glances/'
14 makedepends=('python-setuptools')
15 depends=('python' 'python-psutil' 'python-future' 'python-defusedxml' 'python-ujson')
16 optdepends=('hddtemp: HDD temperature monitoring support'
17 'python-bottle: web server support'
18 'python-docker: for the Docker monitoring support'
19 'python-matplotlib: for graphical/chart support'
20 'python-netifaces: for the IP plugin'
21 'python-zeroconf: for the autodiscover mode'
22 'python-pystache: templating engine'
23 'python-prometheus_client: for the Prometheus export module')
24 source=("${pkgname}-${pkgver}-${pkgrel}.tar.gz::https://github.com/nicolargo/glances/archive/v${pkgver}.tar.gz"
26 sha512sums=('92ec204f646a7fadcc38585fc23394a271b3cc64b1cefc4668e3d5cfc42765dd4d1e02d2baf7521b2115cc7400dbedb36a9070a99dd1dd8a547dcabf665df974'
27 '49f0d185a37a5c5837e5beb463770c943ede40b2f1b8405e338129e897e97d9fc58373a8586fabc506266e6343cfea3c91b9787ac6832cc97a1ab63d6ad058d4')
28 b2sums=('d0647cf2d389c595b0c96b8518af59d9581252dd5179ca8234c2dd3ab782b004c03f1c2b4570c165a1c85c6adb50eb12e7d9b5a0988c316d4df5cb34a258a20a'
29 'ecc44f8c06b1e8624cec92e41422a65d11e024b9fc23bae09b4e52fbedeb172a5034e5b612bbff7ba93d45189fb25eda0d54bc47b22b7f3f0acba984391e4017')
32 cd "glances-${pkgver}"
33 python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
34 install -Dm644 "${srcdir}"/glances.service \
35 "${pkgdir}"/usr/lib/systemd/system/glances.service
38 # vim:set ts=2 sw=2 et: