archrelease: copy trunk to community-any
[ArchLinux/community.git] / gmt / trunk / PKGBUILD
blob9da16480df9d48d5462cfd066cc9df2feb5ffd15
1 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 pkgbase=gmt
4 pkgname=(gmt gmt-doc)
5 pkgver=6.4.0
6 pkgrel=3
7 pkgdesc="Generic Mapping Tools for manipulating and plotting geographic and cartesian data"
8 arch=(x86_64)
9 url="https://www.generic-mapping-tools.org"
10 license=(LGPL)
11 makedepends=(cmake blas curl ffmpeg fftw gdal geos ghostscript graphicsmagick lapack openmp netcdf pcre zlib)
12 source=(https://github.com/GenericMappingTools/gmt/releases/download/${pkgver}/${pkgname}-${pkgver}-src.tar.xz)
13 sha256sums=('b46effe59cf96f50c6ef6b031863310d819e63b2ed1aa873f94d70c619490672')
15 build() {
16   cmake -B build -S ${pkgname}-${pkgver} \
17     -DCMAKE_BUILD_TYPE=Release \
18     -DCMAKE_INSTALL_PREFIX=/usr \
19     -DGMT_LIBDIR=lib \
20     -DGMT_DATADIR=share/gmt \
21     -DGMT_MANDIR=share/man \
22     -DGMT_DOCDIR=share/doc/gmt \
23     -DGMT_ENABLE_OPENMP=ON \
24     -DGSHHG_ROOT=/usr/share/gmt/coast \
25     -DDCW_ROOT=/usr/share/gmt/dcw \
26     -DCOPY_GSHHG=OFF \
27     -DCOPY_DCW=OFF
28   make -C build
31 package_gmt() {
32   depends=(blas curl fftw gdal geos lapack openmp netcdf pcre zlib)
33   optdepends=(
34     'gmt-doc: documentation'
35     'ffmpeg: generate movies'
36     'ghostscript: convert PostScript outputs'
37     'graphicsmagick: generate animated GIFs'
38   )
39 #    'gmt-coast: coastlines'
40 #    'gmt-dcw: digital chart of the world polygon map'
42   make -C build DESTDIR="${pkgdir}" install
43   mv "${pkgdir}"/usr/share/doc "${srcdir}"/
46 package_gmt-doc() {
47   install -d "${pkgdir}"/usr/share/
48   mv doc "${pkgdir}"/usr/share/