archrelease: copy trunk to community-any
[ArchLinux/community.git] / gnome-recipes / trunk / PKGBUILD
blobbbfefbe5a3b0b733302b21ced429818f07441037
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgname=gnome-recipes
4 pkgver=2.0.4
5 pkgrel=4
6 pkgdesc='Recipe management application for GNOME'
7 arch=('x86_64')
8 url='https://wiki.gnome.org/Apps/Recipes'
9 license=('GPL3')
10 groups=('gnome-extra')
11 depends=('cairo' 'dconf' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'gnome-autoar'
12          'gnome-online-accounts' 'gspell' 'gtk3' 'hicolor-icon-theme' 'json-glib' 'libcanberra'
13          'libsoup' 'pango' 'rest')
14 makedepends=('itstool' 'meson')
15 source=("https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz")
16 sha256sums=('b30e96985f66fe138a17189c77af44d34d0b4c859b304ebdb52033bc2cd3ffed')
18 build() {
19   arch-meson $pkgname-$pkgver build
20   meson compile -C build
23 check() {
24   meson test -C build
27 package() {
28   meson install -C build --destdir "$pkgdir"