1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Contributor: Harish Rajagopal <harish dot rajagopals at gmail dot com>
5 pkgname=greetd-${_pkgname,,}
8 pkgdesc='Clean and customizable greeter for greetd'
9 url="https://github.com/rharish101/$_pkgname"
16 provides=(greetd-greeter)
17 backup=("etc/greetd/${_pkgname,,}.toml")
19 _archive="$_pkgname-$pkgver"
20 source=("$url/archive/$pkgver/$_archive.tar.gz"
22 sha256sums=('fa0092498329cfc1ad9d23913c00c7b89c6cb2eb791e1754411c54f1b2d35282'
23 'b80b3eb31f8cc463d512c9db0eef899bdbe232d977429a8a12e95a3b6df2e387')
27 cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
32 cargo build --frozen --release --all-features
37 cargo test --frozen --all-features
42 install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${_pkgname,,}"
43 install -Dm0644 -t "$pkgdir/etc/greetd/" ../"${_pkgname,,}.toml"
44 install -Dm0644 -t "$pkgdir/usr/share/doc/$pkgname/" "${_pkgname,,}.sample.toml"
45 install -Dm0644 systemd-tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/${_pkgname,,}.conf"