archrelease: copy trunk to community-any
[ArchLinux/community.git] / gtk-theme-elementary / trunk / PKGBUILD
blobe97bf8ee0bcc19a91afbe5ab1ed3b3c97c0538e9
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=gtk-theme-elementary
4 pkgver=7.2.0
5 pkgrel=1
6 pkgdesc='elementary GTK theme'
7 arch=(any)
8 url=https://github.com/elementary/stylesheet
9 license=(GPL3)
10 groups=(pantheon)
11 makedepends=(
12   git
13   meson
14   sassc
16 optdepends=('gtk-engine-murrine: GTK2 theme')
17 _tag=715f74608149d5b1cc139583f0a2d3ac44db2f24
18 source=(gtk-theme-elementary::git+https://github.com/elementary/stylesheet.git#tag=${_tag})
19 sha256sums=(SKIP)
21 pkgver() {
22   cd gtk-theme-elementary
23   git describe --tags
26 build() {
27   arch-meson gtk-theme-elementary build
28   ninja -C build
31 package() {
32   DESTDIR="${pkgdir}" ninja -C build install
35 # vim: ts=2 sw=2 et: