archrelease: copy trunk to community-any
[ArchLinux/community.git] / gtkspell3 / trunk / PKGBUILD
blobf3b5e701a3b00418d699dd91cda1326ec3cec3c8
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Roman Kyrylych <roman@archlinux.org>
3 # Contributor: Ben <ben@benmazer.net>
5 pkgname=gtkspell3
6 pkgver=3.0.10
7 pkgrel=2
8 pkgdesc='Provides word-processor-style highlighting and replacement of misspelled words in a GtkTextView widget'
9 arch=('x86_64')
10 url='http://gtkspell.sourceforge.net/'
11 license=('GPL')
12 depends=('gtk3' 'enchant')
13 makedepends=('intltool' 'gobject-introspection' 'vala')
14 source=("https://downloads.sourceforge.net/gtkspell/$pkgname-$pkgver.tar.xz")
15 sha256sums=('b040f63836b347eb344f5542443dc254621805072f7141d49c067ecb5a375732')
17 build() {
18   cd $pkgname-$pkgver
19   ./configure --prefix=/usr
20   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
21   make
24 package() {
25   cd $pkgname-$pkgver
26   make DESTDIR="$pkgdir" install