archrelease: copy trunk to community-any
[ArchLinux/community.git] / gupnp-tools / trunk / PKGBUILD
blobad13a7b3e1ac391a181de54c1aaac311a5b8621d
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgname=gupnp-tools
4 pkgver=0.12.0
5 pkgrel=1
6 pkgdesc="Utilities and demos to work with UPnP"
7 url="https://wiki.gnome.org/Projects/GUPnP"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(gtksourceview4 gupnp gupnp-av)
11 makedepends=(meson git)
12 _commit=8886f95134d95e49d859512fc0c2c62ed63a72b2  # tags/gupnp-tools-0.12.0^0
13 source=("git+https://gitlab.gnome.org/GNOME/gupnp-tools.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/^gupnp-tools-//;s/[^-]*-g/r&/;s/-/+/g'
21 build() {
22   arch-meson $pkgname build
23   meson compile -C build
26 check() {
27   meson test -C build --print-errorlogs
30 package() {
31   meson install -C build --destdir "$pkgdir"
34 # vim:set sw=2 sts=-1 et: