1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
8 pkgdesc="Amazon Web Services (AWS) for Haskell"
9 url="https://github.com/aristidb/aws"
12 depends=('ghc-libs' 'haskell-aeson' 'haskell-attoparsec' 'haskell-base16-bytestring'
13 'haskell-base64-bytestring' 'haskell-blaze-builder' 'haskell-byteable'
14 'haskell-case-insensitive' 'haskell-cereal' 'haskell-conduit' 'haskell-conduit-extra'
15 'haskell-cryptonite' 'haskell-data-default' 'haskell-http-conduit'
16 'haskell-http-client-tls' 'haskell-http-types' 'haskell-lifted-base' 'haskell-memory'
17 'haskell-monad-control' 'haskell-network' 'haskell-network-bsd' 'haskell-old-locale'
18 'haskell-resourcet' 'haskell-safe' 'haskell-scientific' 'haskell-tagged'
19 'haskell-unordered-containers' 'haskell-utf8-string' 'haskell-vector' 'haskell-xml-conduit')
20 makedepends=('ghc' 'haskell-quickcheck' 'haskell-errors' 'haskell-http-client'
21 'haskell-http-client-tls' 'haskell-quickcheck-instances' 'haskell-tasty'
22 'haskell-tasty-hunit' 'haskell-tasty-quickcheck' 'haskell-transformers-base')
23 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
24 sha512sums=('d453ea185a47b0fb93d2e8849ea81e1b0bae081aa81d280f94618d8fb357b6e4b71a43a6c8df0e4ba2b64390346daf50672ed9f9849cc6737a5ae58b5ac52af8')
29 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
30 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
31 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
33 runhaskell Setup build $MAKEFLAGS
34 runhaskell Setup register --gen-script
35 runhaskell Setup unregister --gen-script
36 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
37 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
42 runhaskell Setup test || echo "Requires AWS credentials to test"
48 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
49 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
50 runhaskell Setup copy --destdir="$pkgdir"
51 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
52 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE