1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
7 pkgdesc="Bidirectional mapping between two key types"
8 url="https://github.com/joelwilliamson/bimap"
12 makedepends=('ghc' 'haskell-quickcheck')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('677f15b491e5aaf3dd8d96bc79ba8a7702879dbd8f8220b813f45a38608989ae604fb9c63bb010c31496efd8af716d811a38f3f74a7d65cacd14ff8db220ed40')
19 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22 runhaskell Setup build $MAKEFLAGS
23 runhaskell Setup register --gen-script
24 runhaskell Setup unregister --gen-script
25 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 runhaskell Setup test --show-details=direct
37 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
38 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
39 runhaskell Setup copy --destdir="$pkgdir"
40 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
41 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE