archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-bitvec / repos / community-x86_64 / PKGBUILD
blobb35ca9bb9c20c1c7e7f968ea51bf0c5b82320492
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=bitvec
4 pkgname=haskell-bitvec
5 pkgver=1.1.3.0
6 pkgrel=46
7 pkgdesc="Space-efficient bit vectors"
8 url="https://github.com/Bodigrim/bitvec"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-primitive' 'haskell-vector')
12 makedepends=('ghc' 'uusi' 'haskell-quickcheck-classes' 'haskell-quickcheck-classes-base' 'haskell-tasty'
13              'haskell-tasty-quickcheck')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('1c4c3af50a1fcf46e46e2fa9e0493fffaf62de3607ae7553d18015f8a1a60551')
17 prepare() {
18   cd $_hkgname-$pkgver
19   gen-setup
22 build() {
23   cd $_hkgname-$pkgver
25   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-bitvec --enable-tests \
27     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
29     --ghc-option='-pie' \
30     -flibgmp
32   runhaskell Setup build $MAKEFLAGS
33   runhaskell Setup register --gen-script
34   runhaskell Setup unregister --gen-script
35   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
36   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
39 check() {
40   cd $_hkgname-$pkgver
41   runhaskell Setup test --show-details=direct
44 package() {
45   cd $_hkgname-$pkgver
47   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
48   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
49   runhaskell Setup copy --destdir="$pkgdir"
50   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
51   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE