archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-bytes / repos / community-x86_64 / PKGBUILD
blob1f34460c284c5bee91ec7c79f21a3b85d3820eb8
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=bytes
4 pkgname=haskell-bytes
5 pkgver=0.17.2
6 pkgrel=49
7 pkgdesc="Sharing code for serialization between binary and cereal"
8 url="https://github.com/ekmett/bytes"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-binary-orphans' 'haskell-cereal' 'haskell-hashable'
12          'haskell-scientific' 'haskell-transformers-compat' 'haskell-unordered-containers'
13          'haskell-void')
14 makedepends=('ghc')
15 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
16 sha256sums=('bc55f41edad589bc0ba389e8b106d7425a87390dcd5f1371e3194a9cc2c4781a')
18 build() {
19   cd $_hkgname-$pkgver
21   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-bytes --enable-tests \
23     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
24     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
25     --ghc-option='-pie' 
27   runhaskell Setup build $MAKEFLAGS
28   runhaskell Setup register --gen-script
29   runhaskell Setup unregister --gen-script
30   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35   cd $_hkgname-$pkgver
36   runhaskell Setup test --show-details=direct
39 package() {
40   cd $_hkgname-$pkgver
42   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44   runhaskell Setup copy --destdir="$pkgdir"
45   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
46   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE