1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
7 pkgdesc="Sharing code for serialization between binary and cereal"
8 url="https://github.com/ekmett/bytes"
11 depends=('ghc-libs' 'haskell-binary-orphans' 'haskell-cereal' 'haskell-hashable'
12 'haskell-scientific' 'haskell-transformers-compat' 'haskell-unordered-containers'
15 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
16 sha256sums=('bc55f41edad589bc0ba389e8b106d7425a87390dcd5f1371e3194a9cc2c4781a')
21 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-bytes --enable-tests \
23 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
24 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
27 runhaskell Setup build $MAKEFLAGS
28 runhaskell Setup register --gen-script
29 runhaskell Setup unregister --gen-script
30 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 runhaskell Setup test --show-details=direct
42 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44 runhaskell Setup copy --destdir="$pkgdir"
45 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
46 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE